CM Gift Card Documentation / Overview / Technical Requirements

Technical Requirements

  • Joomla! 3.9.x, 3.10.x or 4.x.x: CM Gift Card is only compatible with Joomla! 3.9.x, 3.10.x, 4.x.x. Any older versions of Joomla!, for example Joomla! 3.5.x, is not supported. Please check Joomla!‘s Technical Requirements for more information.
  • Bootstrap 4 or Bootstrap 5: CM Gift Card is compatible with both Bootstrap 4 and Bootstrap 5 and requires one of these versions available on your site.
  • Cron job: You need cron job to send electronic gift cards on their specific delivery dates.
  • mPDF library: You need mPDF library if you want to send PDF invoice to customer.